aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Willmann <dwillmann@sysmocom.de>2015-12-15 15:10:31 +0100
committerDaniel Willmann <dwillmann@sysmocom.de>2015-12-15 15:10:31 +0100
commit29b9e00355d148be2500d361f2f284e6fa86bab9 (patch)
tree00ef16ebc16fcfb20fa79148bec30d304eda260e /src/Makefile.am
parenta7b02405be1617c6b643fabb34275dc2559b8210 (diff)
Autotoolize the build
Use Autoconf/make for building and autotest for tests
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..d6498b2
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,25 @@
+SUBDIRS = hnbap rua ranap tests
+
+ASN1_ROOT = $(top_builddir)/asn1/
+ASN1TOSTRUCT = $(ASN1_ROOT)/utils/asn1tostruct.py
+
+AM_CFLAGS = $(OSMOCORE_CFLAGS) $(OSMOVTY_CFLAGS) $(OSMOGSM_CFLAGS) $(ASN1C_CFLAGS) -Ihnbap/
+COMMON_LDADD = -lsctp
+
+bin_PROGRAMS = hnbgw
+
+hnbgw_SOURCES = hnbap_encoder.c hnbap_decoder.c rua_encoder.c rua_decoder.c ranap_common.c rua_common.c hnbap_common.c iu_helpers.c asn1helpers.c hnbgw.c hnbgw_hnbap.c hnbgw_rua.c hnbgw_ranap.c
+hnbgw_LDADD = $(OSMOCORE_LIBS) $(OSMOVTY_LIBS) $(OSMOGSM_LIBS) $(ASN1C_LIBS) $(COMMON_LDADD) hnbap/libosmo-asn1-hnbap.a rua/libosmo-asn1-rua.a ranap/libosmo-asn1-ranap.a
+
+
+.PHONY: hnbap_encoder.c
+hnbap_encoder.c : $(ASN1_ROOT)/hnbap/HNBAP-PDU-Contents.asn
+ $(ASN1TOSTRUCT) -f $<
+
+.PHONY: rua_encoder.c
+rua_encoder.c : $(ASN1_ROOT)/rua/RUA-PDU-Contents.asn
+ $(ASN1TOSTRUCT) -p RUA_ -f $<
+
+.PHONY: ranap_encoder.c
+ranap_encoder.c : $(ASN1_ROOT)/ranap/RANAP-PDU-Contents.asn
+ $(ASN1TOSTRUCT) -p RANAP_ -f $<