aboutsummaryrefslogtreecommitdiffstats
path: root/tests/gsup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/gsup/Makefile.am')
-rw-r--r--tests/gsup/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/tests/gsup/Makefile.am b/tests/gsup/Makefile.am
new file mode 100644
index 0000000..5dbb180
--- /dev/null
+++ b/tests/gsup/Makefile.am
@@ -0,0 +1,36 @@
+AM_CPPFLAGS = \
+ $(all_includes) \
+ $(NULL)
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/include \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(NULL)
+
+AM_LDFLAGS = \
+ -no-install \
+ $(NULL)
+
+EXTRA_DIST = \
+ gsup_test.ok \
+ gsup_test.err \
+ $(NULL)
+
+noinst_PROGRAMS = \
+ gsup_test \
+ $(NULL)
+
+gsup_test_SOURCES = \
+ gsup_test.c \
+ $(NULL)
+
+gsup_test_LDADD = \
+ $(top_builddir)/src/gsupclient/libosmo-gsup-client.la \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(NULL)
+
+.PHONY: update_exp
+update_exp:
+ $(builddir)/gsup_test >"$(srcdir)/gsup_test.ok" 2>"$(srcdir)/gsup_test.err"