aboutsummaryrefslogtreecommitdiffstats
path: root/src/mslookup/Makefile.am
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-11-20 10:56:35 +0100
committerlaforge <laforge@osmocom.org>2020-01-10 16:07:40 +0000
commitf10463c5fc6d9e786ab7c648d99f7450f9a25906 (patch)
tree006f7ac6dccc6d608fb73d1eea5ec0ee919356fb /src/mslookup/Makefile.am
parentbf7deda0fc30dba8cdd8f3cc9d5047f9800ca50f (diff)
add mDNS lookup method to libosmo-mslookup
Add the first actually useful lookup method to the mslookup library: multicast DNS. The server side is added in a subsequent commit, when the mslookup server is implemented for the osmo-hlr program. Use custom DNS encoding instead of libc-ares (which we use in OsmoSGSN already), because libc-ares is only a DNS client implementation and we will need both client and server. Related: OS#4237 Patch-by: osmith, nhofmeyr Change-Id: I03a0ffa1d4dc1b24ac78a5ad0975bca90a49c728
Diffstat (limited to 'src/mslookup/Makefile.am')
-rw-r--r--src/mslookup/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/mslookup/Makefile.am b/src/mslookup/Makefile.am
index 01be401..07fb6f4 100644
--- a/src/mslookup/Makefile.am
+++ b/src/mslookup/Makefile.am
@@ -10,9 +10,14 @@ AM_LDFLAGS = $(COVERAGE_LDFLAGS)
lib_LTLIBRARIES = libosmo-mslookup.la
libosmo_mslookup_la_SOURCES = \
+ mdns.c \
+ mdns_msg.c \
+ mdns_rfc.c \
+ mdns_sock.c \
mslookup.c \
mslookup_client.c \
mslookup_client_fake.c \
+ mslookup_client_mdns.c \
$(NULL)
libosmo_mslookup_la_LDFLAGS = -version-info $(LIBVERSION)