aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-01-30 23:30:26 +0100
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-02-01 13:58:50 +0100
commit7685a7875743f6ccc72f814d7c620214703ddeba (patch)
treed820e05190bd433ba962069d8263617b25bfe60c /src/Makefile.am
parent7f9491fe5fa8b4e6dba1bf4087c5aede2fd1daf9 (diff)
main: add VTY and '-c config-file' option
Add config file, mainly for logging control. Open VTY on the OMSO_VTY_PORT_HLR added to libosmocore in commit 92fa18e6b800a27aa064a5fb8321cddd7383ae20 aka change-id I08cb52d9399a27e6876e45da36f434708c4fddef. Add hlr_vty.h/c for standard VTY setup. Add -c option to pass config file. Add --version option. Change-Id: Iedb884345a597371a337b0c67eb6013b7d5d1ce1
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6c6c9e6..9bbc13e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,6 +18,7 @@ noinst_HEADERS = \
gsup_server.h \
logging.h \
rand.h \
+ hlr_vty.h \
$(NULL)
bin_PROGRAMS = \
@@ -38,6 +39,7 @@ osmo_hlr_SOURCES = \
hlr.c \
logging.c \
rand_urandom.c \
+ hlr_vty.c \
$(NULL)
osmo_hlr_LDADD = \