aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2020-01-30 09:55:00 +0100
committerosmith <osmith@sysmocom.de>2020-02-14 11:16:47 +0000
commitf0e90e6bd5e5b2be17253e357a0521da42dc43aa (patch)
tree484363aa6c6a0bbe7f3b43f421cf02cbb1279b27 /configure.ac
parent15ad7bef5ff62965e208d9f6bb9830450085c25f (diff)
mslookup_client_mdns_test: disable by default
Only build and run the test, if --enable-mslookup-client-mdns-test is passed to ./configure. Enable that option in jenkins.sh. Related: OS#4385 Change-Id: Ie0cd4b0c55a1fbb00c215aeec7dcd0c15805add3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 59261e8..34c5163 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,6 +107,15 @@ AC_MSG_CHECKING([whether to enable VTY/CTRL tests])
AC_MSG_RESULT([$enable_ext_tests])
AM_CONDITIONAL(ENABLE_EXT_TESTS, test "x$enable_ext_tests" = "xyes")
+# mslookup_client_mdns_test (OS#4385: does not work everywhere)
+AC_ARG_ENABLE([mslookup_client_mdns_test],
+ AC_HELP_STRING([--enable-mslookup-client-mdns-test],
+ [Include the mslookup_client_mdns_test in make check [default=no]]),
+ [enable_mslookup_client_mdns_test="$enableval"],[enable_mslookup_client_mdns_test="no"])
+AC_MSG_CHECKING([whether to enable mslookup_client_mdns_test])
+AC_MSG_RESULT([$enable_mslookup_client_mdns_test])
+AM_CONDITIONAL(ENABLE_MSLOOKUP_CLIENT_MDNS_TEST, test "x$enable_mslookup_client_mdns_test" = "xyes")
+
# Generate manuals
AC_ARG_ENABLE(manuals,
[AS_HELP_STRING(