aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-11-20 10:56:35 +0100
committerlaforge <laforge@osmocom.org>2020-01-10 16:07:40 +0000
commitbf7deda0fc30dba8cdd8f3cc9d5047f9800ca50f (patch)
treee93fac5ab953405b086ed182037298c53ccb9788 /configure.ac
parent81b92bbe69fdc548680af651a44071d948a50292 (diff)
add libosmo-mslookup abstract client
mslookup is a key concept in Distributed GSM, which allows querying the current location of a subscriber in a number of cooperating but independent core network sites, by arbitrary service names and by MSISDN/IMSI. Add the abstract mslookup client library. An actual lookup method (besides mslookup_client_fake.c) is added in a subsequent patch. For a detailed overview of this and upcoming patches, please see the elaborate comment at the top of mslookup.c. Add as separate library, libosmo-mslookup, to allow adding D-GSM capability to arbitrary client programs. osmo-hlr will be the only mslookup server implementation, added in a subsequent patch. osmo-hlr itself will also use this library and act as an mslookup client, when requesting the home HLR for locally unknown IMSIs. Related: OS#4237 Patch-by: osmith, nhofmeyr Change-Id: I83487ab8aad1611eb02e997dafbcb8344da13df1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 334a7e8..217df9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,10 +174,12 @@ AC_OUTPUT(
doc/examples/Makefile
src/Makefile
src/gsupclient/Makefile
+ src/mslookup/Makefile
include/Makefile
include/osmocom/Makefile
include/osmocom/hlr/Makefile
libosmo-gsup-client.pc
+ libosmo-mslookup.pc
sql/Makefile
doc/manuals/Makefile
contrib/Makefile
@@ -188,4 +190,5 @@ AC_OUTPUT(
tests/gsup_server/Makefile
tests/db/Makefile
tests/db_upgrade/Makefile
+ tests/mslookup/Makefile
)