aboutsummaryrefslogtreecommitdiffstats
path: root/sgsnemu/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Bretelle <chantra@debuntu.org>2010-09-07 17:01:20 +0200
committerHarald Welte <laforge@gnumonks.org>2010-10-20 11:04:51 +0200
commit2a103687b6c08c95b96ccf447ef096bc7e54d7ae (patch)
treed6c6aca9fdf604f2a16cc1d7c4ad80986c271228 /sgsnemu/Makefile.am
parent2a7cad57efcd70a660d1619a8eb4f8efc88bb0d8 (diff)
Move common sgsnemu/ggsn files to directory "lib"
Some files like in sgsnemu and ggsn directory where exactly the same. They are now moved to the same directory for easier maintenance Signed-off-by: Emmanuel Bretelle <chantra@debuntu.org>
Diffstat (limited to 'sgsnemu/Makefile.am')
-rw-r--r--sgsnemu/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/sgsnemu/Makefile.am b/sgsnemu/Makefile.am
index f2f930d..eecd9fd 100644
--- a/sgsnemu/Makefile.am
+++ b/sgsnemu/Makefile.am
@@ -1,5 +1,7 @@
bin_PROGRAMS = sgsnemu
+AUTOMAKE_OPTIONS = subdir-objects
+
AM_LDFLAGS = @EXEC_LDFLAGS@
AM_CFLAGS = -O2 -D_GNU_SOURCE -fno-builtin -Wall -DSBINDIR='"$(sbindir)"' -ggdb
@@ -8,4 +10,5 @@ sgsnemu_LDADD = @LIBOBJS@ @EXEC_LDADD@ -lgtp -L../gtp
#sgsnemu_DEPENDENCIES = ../gtp/libgtp.la
-sgsnemu_SOURCES = sgsnemu.c tun.c tun.h cmdline.c cmdline.h ippool.h ippool.c syserr.h syserr.c lookup.c lookup.h
+sgsnemu_SOURCES = sgsnemu.c ../lib/tun.c ../lib/tun.h cmdline.c cmdline.h ../lib/ippool.h ../lib/ippool.c ../lib/syserr.h ../lib/syserr.c ../lib/lookup.c ../lib/lookup.h
+#sgsnemu_SOURCES = sgsnemu.c cmdline.c cmdline.h