aboutsummaryrefslogtreecommitdiffstats
path: root/doc/manuals/Makefile.am
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2018-11-14 10:47:01 +0100
committerNeels Hofmeyr <neels@hofmeyr.de>2018-11-27 18:28:24 +0100
commitbf47f717854d0d460da156a565eae1141793ce58 (patch)
tree6be0e535cbb8c28ba1282bb8bdfe48b833763ef6 /doc/manuals/Makefile.am
parent2b7a860ffb493aef75e7fc6f67574e1eb3663761 (diff)
build manuals moved here from osmo-gsm-manuals.git
Moved to doc/manuals/, with full commit history, in preceding merge commit. Now incorporate in the build system. Build with: $ autoreconf -fi $ ./configure --enable-manuals $ make Shared files from osmo-gsm-manuals.git are found automatically if - the repository is checked out in ../osmo-gsm-manuals; or - if it osmo-gsm-manuals was installed with "make install"; or - OSMO_GSM_MANUALS_DIR is set. Related: OS#3385 Change-Id: I14533676d5774ee0d0ee5054ba77d7dac32cff43
Diffstat (limited to 'doc/manuals/Makefile.am')
-rw-r--r--doc/manuals/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/doc/manuals/Makefile.am b/doc/manuals/Makefile.am
new file mode 100644
index 0000000..d41ca2c
--- /dev/null
+++ b/doc/manuals/Makefile.am
@@ -0,0 +1,16 @@
+EXTRA_DIST = osmoggsn-usermanual.adoc \
+ osmoggsn-usermanual-docinfo.xml \
+ osmoggsn-vty-reference.xml \
+ chapters \
+ vty
+
+if BUILD_MANUALS
+ ASCIIDOC = osmoggsn-usermanual.adoc
+ ASCIIDOC_DEPS = $(srcdir)/chapters/*.adoc
+ include $(OSMO_GSM_MANUALS_DIR)/build/Makefile.asciidoc.inc
+
+ VTY_REFERENCE = osmoggsn-vty-reference.xml
+ include $(OSMO_GSM_MANUALS_DIR)/build/Makefile.vty-reference.inc
+
+ include $(OSMO_GSM_MANUALS_DIR)/build/Makefile.common.inc
+endif