aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Schultz <aschultz@tpip.net>2015-11-17 12:22:44 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-12-21 08:37:50 +0100
commitc80680a9c42f378268daa911f9f5bff270bbd32f (patch)
treeb6aee620ebc3c10be847fdadbc1408356de5bdc6 /configure.ac
parentc5fbf9bd68432e9e18b62a6ee9c1be149e3f427a (diff)
ggsn: fix autotool pkg-config invokation
see https://autotools.io/pkgconfig/pkg_check_modules.html, Optional Modules for explanation Signed-off-by: Andreas Schultz <aschultz@tpip.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 383fa6d..66c4892 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,9 +50,9 @@ AC_ARG_ENABLE([gtp-kernel],
AS_HELP_STRING([--enable-gtp-kernel], [Build GTP tunneling kernel]),
[enable_gtp_kernel="$enableval"], [enable_gtp_kernel="no"])
-if test "x$enable_gtp_kernel" = "xyes"; then
+AS_IF([test "x$enable_gtp_kernel" = "xyes"], [
PKG_CHECK_MODULES([LIBGTPNL], [libgtpnl >= 1.0.0])
-fi
+])
AM_CONDITIONAL([ENABLE_GTP_KERNEL], [test "$enable_gtp_kernel" = "yes"])