aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-10-01 00:51:26 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-10-12 23:26:17 +0000
commit38929c9131b606d074d438a6476c5b032badb46d (patch)
treed0790b79b68c45b1faf189ef112f90cf38023c0c /configure.ac
parentee9d34a9ccc78f69971ec7140bd3a7076d232465 (diff)
configure: check for pkg-config presence
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e4744b3..1a36357 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,13 @@ AC_PROG_CPP
AC_PROG_CXX
LT_INIT
+dnl check for pkg-config (explained in detail in libosmocore/configure.ac)
+AC_PATH_PROG(PKG_CONFIG_INSTALLED, pkg-config, no)
+if test "x$PKG_CONFIG_INSTALLED" = "xno"; then
+ AC_MSG_WARN([You need to install pkg-config])
+fi
+PKG_PROG_PKG_CONFIG([0.20])
+
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_LIBOBJ_DIR([lib])