aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2016-05-10 19:08:29 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2016-05-10 19:11:43 +0200
commit466da999344a44e82c0c0945302f7532a43c4751 (patch)
treea795cc0ec3dc9e3572df66bf523fbf83ef696de9 /configure.ac
parent8419e33c4acd77a80456a6896385c2d9f7255699 (diff)
configure: rename from --enable-gtp-kernel to --enable-gtp-linux
This software seems to run on other *nixes, so indicate explicitly that this is the Linux kernel datapath support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 66c4892..9b8d988 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,16 +45,16 @@ AC_SUBST(EXEC_LDADD)
# FIXME: Replace `main' with a function in `-links':
#AC_CHECK_LIB([inks], [main])
-dnl GTP kernel dependencies
-AC_ARG_ENABLE([gtp-kernel],
- AS_HELP_STRING([--enable-gtp-kernel], [Build GTP tunneling kernel]),
- [enable_gtp_kernel="$enableval"], [enable_gtp_kernel="no"])
+dnl GTP Linux kernel dependencies
+AC_ARG_ENABLE([gtp-linux],
+ AS_HELP_STRING([--enable-gtp-linux], [Build GTP tunneling Linux kernel]),
+ [enable_gtp_linux="$enableval"], [enable_gtp_linux="no"])
-AS_IF([test "x$enable_gtp_kernel" = "xyes"], [
+AS_IF([test "x$enable_gtp_linux" = "xyes"], [
PKG_CHECK_MODULES([LIBGTPNL], [libgtpnl >= 1.0.0])
])
-AM_CONDITIONAL([ENABLE_GTP_KERNEL], [test "$enable_gtp_kernel" = "yes"])
+AM_CONDITIONAL([ENABLE_GTP_KERNEL], [test "$enable_gtp_linux" = "yes"])
# Checks for header files.
AC_HEADER_STDC
@@ -133,4 +133,4 @@ AC_OUTPUT
echo "
openggsn Configuration:
- GTP kernel support: ${enable_gtp_kernel}"
+ GTP Linux kernel support: ${enable_gtp_linux}"