aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-08-02 21:10:09 +0200
committerHarald Welte <laforge@gnumonks.org>2017-08-09 22:09:34 +0200
commit63ebccdfe350d7e75bbb8e5511bcde26a7e300ad (patch)
tree700acfb1b9138c72d43866636270f20cb60d53a1 /configure.ac
parentd12eab9c4e375e1669637dd34674c8b8208cf867 (diff)
lib/tun.h: Remove non-endian-safe redefinition of IP header
We can simply use 'struct iphdr' from netinet/ip.h to achieve the same goal (and be portable). Change-Id: Ieece22e127dc14a7ffdc3b05656628989ad00b32
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 45ab22b..b7e6793 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,12 @@ AC_EGREP_HEADER(rt_msghdr, net/route.h,
AC_DEFINE([HAVE_RT_MSGHDR])],
AC_MSG_RESULT(no))
+AC_MSG_CHECKING(whether struct iphdr exists)
+AH_TEMPLATE(HAVE_IPHDR)
+AC_EGREP_HEADER(struct iphdr, netinet/ip.h,
+[AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_IPHDR])],
+ AC_MSG_RESULT(no))
# Checks for library functions.
AC_PROG_GCC_TRADITIONAL