aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fd61f5a..cf18d60 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -32,6 +32,10 @@ bin_PROGRAMS = \
osmo-e1d-pipe \
$(NULL)
+noinst_PROGRAMS = \
+ osmo-e1gen \
+ $(NULL)
+
osmo_e1d_SOURCES = \
ctl.c \
intf_line.c \
@@ -51,3 +55,17 @@ osmo_e1d_pipe_SOURCES = \
$(NULL)
osmo_e1d_pipe_LDADD = $(LIBOSMOCORE_LIBS) libosmo-e1d.la
+
+
+osmo_e1gen_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOVTY_LIBS) \
+ $(LIBOSMOUSB_LIBS) $(LIBUSB_LIBS)
+
+osmo_e1gen_SOURCES = \
+ intf_line.c \
+ log.c \
+ e1gen/crc4itu.c \
+ e1gen/osmo_e1f.c \
+ osmo-e1gen.c \
+ usb.c \
+ vty.c \
+ $(NULL)