aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control8
-rwxr-xr-xdebian/rules4
2 files changed, 10 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 437335fc..0377d9fd 100644
--- a/debian/control
+++ b/debian/control
@@ -40,3 +40,11 @@ Description: Virtual Osmocom GSM BTS (no RF hardware; GSMTAP/UDP)
This version of OsmoBTS doesn't use actual GSM PHY/Hardware/RF, but
utilizes GSMTAP-over-UDP frames for the Um interface. This is useful
in fully virtualized setups e.g. in combination with OsmocomBB virt_phy.
+
+Package: osmo-bts-virtual-dbg
+Architecture: any
+Section: debug
+Priority: extra
+Depends: osmo-bts-virtual (= ${binary:Version}), ${misc:Depends}
+Description: Debug symbols for the osmo-bts-virtual
+ Make debugging possible
diff --git a/debian/rules b/debian/rules
index 80ba0b2c..32d9342b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,7 +12,8 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
dh $@ --with=systemd --with autoreconf --fail-missing
override_dh_strip:
- dh_strip --dbg-package=osmo-bts-trx-dbg
+ dh_strip --package=osmo-bts-virtual --dbg-package=osmo-bts-virtual-dbg
+ dh_strip --package=osmo-bts-trx --dbg-package=osmo-bts-trx-dbg
override_dh_autoreconf:
echo $(VERSION) > .tarball-version
@@ -29,4 +30,3 @@ override_dh_clean:
# Print test results in case of a failure
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
-