aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 11 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index f7f941b3..80ba0b2c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,7 +5,7 @@ DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
#export DH_VERBOSE=1
-export DEB_BUILD_HARDENING=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
@@ -20,3 +20,13 @@ override_dh_autoreconf:
override_dh_auto_configure:
dh_auto_configure -- --enable-trx
+
+override_dh_clean:
+ dh_clean
+ $(RM) tests/package.m4
+ $(RM) tests/testsuite
+
+# Print test results in case of a failure
+override_dh_auto_test:
+ dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
+