aboutsummaryrefslogtreecommitdiffstats
path: root/tests/handover/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg <jolly@eversberg.eu>2013-06-17 08:23:04 +0200
committerHarald Welte <laforge@gnumonks.org>2015-09-22 16:41:29 +0200
commitda0c44a9db88b866056f19f13364e1362c92773a (patch)
tree09617fbdb7bfa94d60a322380ef052a6533438fb /tests/handover/Makefile.am
parent798c1bba9d48896dc6baa4340e252cda27cb30d2 (diff)
Add test case for successful handover and unsuccessful handover
Diffstat (limited to 'tests/handover/Makefile.am')
-rw-r--r--tests/handover/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/handover/Makefile.am b/tests/handover/Makefile.am
new file mode 100644
index 00000000..a07a527d
--- /dev/null
+++ b/tests/handover/Makefile.am
@@ -0,0 +1,8 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(OPENBSC_INCDIR)
+AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOCODEC_CFLAGS)$(LIBOSMOTRAU_CFLAGS)
+LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOCODEC_LIBS) $(LIBOSMOTRAU_LIBS) $(LIBOSMOABIS_LIBS)
+noinst_PROGRAMS = handover_test
+EXTRA_DIST = handover_test.ok
+
+handover_test_SOURCES = handover_test.c
+handover_test_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)