aboutsummaryrefslogtreecommitdiffstats
path: root/tests/cipher/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-12-26 18:55:54 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-12-26 18:55:54 +0100
commit19cf0e81b336ead3c0a55d1c9d6722f986510bc0 (patch)
treef78ac1ca37b836aa3b7ff1dbfc6b861ac44ab5b4 /tests/cipher/Makefile.am
parent5f408f934ca868ff209049bd92f3b0896a0eccac (diff)
ciphering: Handle ciphering support for A5/3 correctly
This was found and debugged by Sylvain. The BTS will always support A5/0 so we do not keep track of that, the first bit of the flags is used for A5/1, second for A5/2... but for RSL there is an offset to go from RSL to A5(x). Add a testcase and change the code.
Diffstat (limited to 'tests/cipher/Makefile.am')
-rw-r--r--tests/cipher/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/cipher/Makefile.am b/tests/cipher/Makefile.am
new file mode 100644
index 00000000..bd6f15b3
--- /dev/null
+++ b/tests/cipher/Makefile.am
@@ -0,0 +1,8 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(OPENBSC_INCDIR)
+AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(LIBOSMOTRAU_CFLAGS)
+LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) $(LIBOSMOTRAU_LIBS) -lortp
+noinst_PROGRAMS = cipher_test
+EXTRA_DIST = cipher_test.ok
+
+cipher_test_SOURCES = cipher_test.c
+cipher_test_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)