aboutsummaryrefslogtreecommitdiffstats
path: root/tests/agch/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2014-02-21 16:12:46 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-03-10 08:57:38 +0100
commit2d725e77f7270550d7173a7c86f30aa1c7b01e5e (patch)
tree650e848547f23bd92b4c6d42a598c97586139519 /tests/agch/Makefile.am
parent35a8144e41157b0a7304e7a0fd46a0e5a0dda287 (diff)
agch/test: Add test for AGCH queue handling
The first test checks the AGCH may queue length computation. The second test fills the queue by calling bts_agch_enqueue() with a mix of IMM.ASS and IMM.ASS.REJ. Then it drains the queue by calling bts_ccch_copy_msg(). After each of both steps, statistics are printed out. Sponsored-by: On-Waves ehf
Diffstat (limited to 'tests/agch/Makefile.am')
-rw-r--r--tests/agch/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/agch/Makefile.am b/tests/agch/Makefile.am
new file mode 100644
index 00000000..a0c5eeda
--- /dev/null
+++ b/tests/agch/Makefile.am
@@ -0,0 +1,8 @@
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(OPENBSC_INCDIR)
+AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(LIBOSMOTRAU_CFLAGS)
+LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) $(LIBOSMOTRAU_LIBS) $(LIBOSMOABIS_LIBS) -lortp
+noinst_PROGRAMS = agch_test
+EXTRA_DIST = agch_test.ok
+
+agch_test_SOURCES = agch_test.c $(srcdir)/../stubs.c
+agch_test_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)