aboutsummaryrefslogtreecommitdiffstats
path: root/src/osmo-bts-trx/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg <jolly@eversberg.eu>2013-02-05 11:45:28 +0100
committerHarald Welte <laforge@gnumonks.org>2015-09-22 16:41:24 +0200
commitacc71ffb4b61b3354bbb2fa14981e4e6a46946e6 (patch)
treeb32d0f93b6055283a74d70e7c777907e22745739 /src/osmo-bts-trx/Makefile.am
parentc64fa4f88818a63bada0e34d179fd04319de47e1 (diff)
TRX: Introduce osmobts-trx, a layer 1 implementation for OpenBTS tranceivers
The code is quite complete, TCH and PDCH channels are not yet tested.
Diffstat (limited to 'src/osmo-bts-trx/Makefile.am')
-rw-r--r--src/osmo-bts-trx/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/osmo-bts-trx/Makefile.am b/src/osmo-bts-trx/Makefile.am
new file mode 100644
index 00000000..94a050ce
--- /dev/null
+++ b/src/osmo-bts-trx/Makefile.am
@@ -0,0 +1,11 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(OPENBSC_INCDIR)
+AM_CFLAGS = -Wall -fno-strict-aliasing $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(LIBOSMOTRAU_CFLAGS) $(LIBOSMOABIS_CFLAGS)
+LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) $(LIBOSMOTRAU_LIBS) $(LIBOSMOABIS_LIBS) -lortp
+
+EXTRA_DIST = trx_if.h l1_if.h scheduler.h xcch.h rach.h sch.h pxxch.h tch_fr.h
+
+bin_PROGRAMS = osmobts-trx
+
+osmobts_trx_SOURCES = main.c trx_if.c l1_if.c scheduler.c trx_vty.c xcch.c rach.c sch.c pxxch.c tch_fr.c
+osmobts_trx_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)
+