aboutsummaryrefslogtreecommitdiffstats
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-06-29 10:36:07 +0200
committerHarald Welte <laforge@gnumonks.org>2011-06-29 10:36:07 +0200
commit6818881d72cdde04eca4b1923a805190acde493c (patch)
tree02a808116ca27e88637e8880a02261b69138fbe3 /src/common/Makefile.am
parentc5e01c8bd463e42ea3bbe4142941f43c548f14c7 (diff)
implement baseic uplink measurement processing + reporting
* gather measurements from each PH-DATA.ind * check every TDMA frame about meas period expiration * compute averages after period expired * put MS DL MEAS REP into RSL MEAS RES messages, include UL meas bugs: * L3 INFO content seems to have some offset * is_sub is not set anywhere * measurement periods might have up/downlink offset
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 70b94957..c8530c40 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -3,5 +3,6 @@ AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS)
LDADD = $(LIBOSMOCORE_LIBS)
noinst_LIBRARIES = libbts.a
-libbts_a_SOURCES = gsm_data_shared.c sysinfo.c logging.c abis.c oml.c bts.c rsl.c vty.c paging.c
+libbts_a_SOURCES = gsm_data_shared.c sysinfo.c logging.c abis.c oml.c bts.c \
+ rsl.c vty.c paging.c measurement.c
#support.c rtp.c