aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-04-05 14:08:11 +0200
committerosmith <osmith@sysmocom.de>2019-05-20 10:28:45 +0000
commitad7b8bee71e78e5a046b65898e181b8c48be3974 (patch)
treeb470c41fb38149ce6c3a29e549fe434d343c594d /debian
parentc6c2aa9ecdeba74de4ddc51320de5fd674a5702a (diff)
debian: create -doc subpackage with pdf manuals
Diffstat (limited to 'debian')
-rw-r--r--debian/control12
-rw-r--r--debian/osmo-bts-doc.install1
-rwxr-xr-xdebian/rules6
3 files changed, 17 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 0377d9fd..2b667164 100644
--- a/debian/control
+++ b/debian/control
@@ -11,7 +11,8 @@ Build-Depends: debhelper (>= 9),
libosmocore-dev,
libosmo-abis-dev,
libgps-dev,
- txt2man
+ txt2man,
+ osmo-gsm-manuals-dev
Standards-Version: 3.9.8
Vcs-Browser: http://git.osmocom.org/osmo-bts/
Vcs-Git: git://git.osmocom.org/osmo-bts
@@ -48,3 +49,12 @@ Priority: extra
Depends: osmo-bts-virtual (= ${binary:Version}), ${misc:Depends}
Description: Debug symbols for the osmo-bts-virtual
Make debugging possible
+
+Package: osmo-bts-doc
+Architecture: all
+Section: doc
+Priority: optional
+Depends: ${misc:Depends}
+Description: ${misc:Package} PDF documentation
+ Various manuals: user manual, VTY reference manual and/or
+ protocol/interface manuals.
diff --git a/debian/osmo-bts-doc.install b/debian/osmo-bts-doc.install
new file mode 100644
index 00000000..65aaaf7e
--- /dev/null
+++ b/debian/osmo-bts-doc.install
@@ -0,0 +1 @@
+usr/share/doc/osmo-bts-doc/*.pdf
diff --git a/debian/rules b/debian/rules
index 27de11b8..94bed0ea 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,7 @@ override_dh_strip:
dh_strip --package=osmo-bts-trx --dbg-package=osmo-bts-trx-dbg
override_dh_auto_configure:
- dh_auto_configure -- --enable-trx --with-systemdsystemunitdir=/lib/systemd/system
+ dh_auto_configure -- --enable-trx --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
override_dh_clean:
dh_clean
@@ -26,3 +26,7 @@ override_dh_clean:
# Print test results in case of a failure
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
+
+# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
+override_dh_compress:
+ dh_compress -X.pdf