aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorÁlvaro Neira Ayuso <anayuso@sysmocom.de>2014-03-12 16:19:59 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-03-12 16:27:38 +0100
commite030dfd443f50803835e6525265cdf6a378e334a (patch)
tree10a90a2f9c7cf85ce475c442ad218d8ed8624924 /configure.ac
parent21104720f790eac667f73f012863a59ecbeb58d1 (diff)
misc/sysmobts_misc.c: Read temperature from microcontroller
Add function for requesting the temperature information to the microcontroller. I have added a function that we can extend for requesting more information but in this case we only need to know the temperature. I have added to a microcontroller temperature handling function in the manager for monitoring this information. Signed-off-by: Alvaro Neira Ayuso <anayuso@sysmocom.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff46b5ab..b747a42f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,16 @@ AC_CHECK_HEADER([openbsc/gsm_data_shared.h],[],
[])
CPPFLAGS=$oldCPPFLAGS
+# Check for the sbts2050_header.h that was added after the 3.6 release
+AC_CHECK_HEADER([sysmocom/femtobts/sbts2050_header.h],
+ [sysmo_uc_header="yes"],[])
+
+if test "$sysmo_uc_header" = "yes" ; then
+ AC_DEFINE(BUILD_SBTS2050, 1, [Define if we want to build SBTS2050])
+fi
+AM_CONDITIONAL(BUILD_SBTS2050, test "x$sysmo_uc_header" = "xyes")
+AM_CONFIG_HEADER(btsconfig.h)
+
AC_OUTPUT(
src/Makefile
src/common/Makefile