aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-12-20 00:21:38 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-12-20 19:18:13 +0100
commit56698b84e0e0caa373c74df8e76b5f476aee1d9a (patch)
tree39ffaadd8eefa77add6dd9851c472555fb4bda66 /configure.ac
parentdb51f0d73efda28d4b83703d512cd7137beae9d8 (diff)
openbsc: Check for the presence of the gsm_data_shared.h header file
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ef583d36..e726367b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,9 +40,16 @@ AC_ARG_WITH([openbsc],
[AS_HELP_STRING([--with-openbsc=INCLUDE_DIR],
[OpenBSC include directory for openbsc/gsm_data_shared.h])],
[openbsc_incdir="$withval"],
- [openbsc_incdir="\$(abs_top_srcdir)/../openbsc/openbsc/include"])
+ [openbsc_incdir="`cd $srcdir; pwd`/../openbsc/openbsc/include"])
AC_SUBST([OPENBSC_INCDIR], $openbsc_incdir)
+oldCPPFLAGS=$CPPFLAGS
+CPPFLAGS="$CPPFLAGS -I$OPENBSC_INCDIR $LIBOSMOCORE_CFLAGS"
+AC_CHECK_HEADER([openbsc/gsm_data_shared.h],[],
+ [AC_MSG_ERROR([openbsc/gsm_data_shared.h can not be found in $openbsc_incdir])],
+ [])
+CPPFLAGS=$oldCPPFLAGS
+
AC_OUTPUT(
src/Makefile
src/common/Makefile