aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-03-12 16:51:27 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-03-12 16:51:27 +0100
commit4e3aa9368195110f4de1791587f309846a3c5941 (patch)
treebc88aa0248f2a443c7a8194404993af1102759a7 /configure.ac
parent06387d89e860978511ac5383a6c5a9837b103d1c (diff)
misc/sysmobts: Another small change to help in finding the header
We could have a dedicated configure/cflag for the header files but for now search in the standard directories.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b747a42f..cb601d2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,8 +52,11 @@ AC_CHECK_HEADER([openbsc/gsm_data_shared.h],[],
CPPFLAGS=$oldCPPFLAGS
# Check for the sbts2050_header.h that was added after the 3.6 release
+oldCPPFLAGS=$CPPFLAGS
+CPPFLAGS="$CPPFLAGS -I$OPENBSC_INCDIR $LIBOSMOCORE_CFLAGS"
AC_CHECK_HEADER([sysmocom/femtobts/sbts2050_header.h],
[sysmo_uc_header="yes"],[])
+CPPFLAGS=$oldCPPFLAGS
if test "$sysmo_uc_header" = "yes" ; then
AC_DEFINE(BUILD_SBTS2050, 1, [Define if we want to build SBTS2050])