aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-12-20 00:04:20 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-12-20 19:02:37 +0100
commitdb51f0d73efda28d4b83703d512cd7137beae9d8 (patch)
tree2c312d80e6e96720c2cdde0a290e62b57480374a /configure.ac
parentbcae2abff8dfeaab75b1bbe58c7659285a721822 (diff)
openbsc: Introduce autoconf support to set the OpenBSC include directory
Add autoconf support to set the path to the OpenBSC include directory so that openbsc/gsm_data_shared.h can be found there.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ccca24fc..ef583d36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,7 +36,11 @@ AM_CONDITIONAL(ENABLE_SYSMOBTS, test "x$enable_sysmocom_bts" = "xyes")
# We share gsm_data.h with OpenBSC and need to be pointed to the source
# directory of OpenBSC for now.
-openbsc_incdir="\$(abs_top_srcdir)/../openbsc/openbsc/include"
+AC_ARG_WITH([openbsc],
+ [AS_HELP_STRING([--with-openbsc=INCLUDE_DIR],
+ [OpenBSC include directory for openbsc/gsm_data_shared.h])],
+ [openbsc_incdir="$withval"],
+ [openbsc_incdir="\$(abs_top_srcdir)/../openbsc/openbsc/include"])
AC_SUBST([OPENBSC_INCDIR], $openbsc_incdir)
AC_OUTPUT(