aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-12-19 23:53:34 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-12-20 19:02:37 +0100
commitbcae2abff8dfeaab75b1bbe58c7659285a721822 (patch)
treec85c0be436abf97431610f8203dab295a39b2084 /configure.ac
parentd1ffab96ca64111652fd850982ca00514b5b3531 (diff)
openbsc: Prepare to allow to have the OpenBSC directory somewhere else
Right now osmo-bts requires access to one OpenBSC header file and this requires that openbsc and osmo-bts git are in the same directory. Begin with making the location of the OpenBSC sourcecode configurable. This approach will allow to build osmo-bts on our Jenkins installation but now has the risk of more code including the openbsc/*.h header files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7330df86..ccca24fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,11 @@ AC_ARG_ENABLE(sysmocom-bts,
AC_MSG_RESULT([$enable_sysmocom_bts])
AM_CONDITIONAL(ENABLE_SYSMOBTS, test "x$enable_sysmocom_bts" = "xyes")
+# We share gsm_data.h with OpenBSC and need to be pointed to the source
+# directory of OpenBSC for now.
+openbsc_incdir="\$(abs_top_srcdir)/../openbsc/openbsc/include"
+AC_SUBST([OPENBSC_INCDIR], $openbsc_incdir)
+
AC_OUTPUT(
src/Makefile
src/common/Makefile