aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am29
1 files changed, 0 insertions, 29 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7e17ad8de..fc7fc570d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,14 +1,10 @@
SUBDIRS = \
gsm0408 \
channel \
- gprs \
abis \
- gbproxy \
trau \
subscr \
nanobts_omlattr \
- sms_queue \
- msc_vlr \
$(NULL)
if BUILD_NAT
@@ -22,27 +18,6 @@ SUBDIRS += \
bsc \
$(NULL)
endif
-if BUILD_SMPP
-SUBDIRS += \
- smpp \
- $(NULL)
-endif
-if HAVE_LIBGTP
-SUBDIRS += \
- gtphub \
- $(NULL)
-
-if HAVE_LIBCARES
-SUBDIRS += \
- sgsn \
- oap \
- xid \
- sndcp_xid \
- slhc \
- v42bis \
- $(NULL)
-endif
-endif
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
@@ -68,7 +43,6 @@ EXTRA_DIST = \
$(TESTSUITE) \
vty_test_runner.py \
ctrl_test_runner.py \
- smpp_test_runner.py \
$(NULL)
TESTSUITE = $(srcdir)/testsuite
@@ -83,9 +57,6 @@ python-tests: $(BUILT_SOURCES)
osmotestconfig.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
$(PYTHON) $(srcdir)/vty_test_runner.py -w $(abs_top_builddir) -v
$(PYTHON) $(srcdir)/ctrl_test_runner.py -w $(abs_top_builddir) -v
-if BUILD_SMPP
- $(PYTHON) $(srcdir)/smpp_test_runner.py -w $(abs_top_builddir) -v
-endif
rm -f $(top_builddir)/sms.db $(top_builddir)/gsn_restart $(top_builddir)/gtphub_restart_count
else
python-tests: $(BUILT_SOURCES)