aboutsummaryrefslogtreecommitdiffstats
path: root/src/libgb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libgb/Makefile.am')
-rw-r--r--src/libgb/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/libgb/Makefile.am b/src/libgb/Makefile.am
new file mode 100644
index 000000000..b48b17791
--- /dev/null
+++ b/src/libgb/Makefile.am
@@ -0,0 +1,9 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall -fno-strict-aliasing $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(LIBOSMOVTY_LIBS) $(COVERAGE_LDFLAGS)
+
+noinst_LIBRARIES = libgb.a
+
+libgb_a_SOURCES = gprs_ns.c gprs_ns_frgre.c gprs_ns_vty.c \
+ gprs_bssgp.c gprs_bssgp_util.c gprs_bssgp_vty.c
+#gprs_llc.c gprs_llc_vty.c crc24.c