aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/Makefile.am')
-rw-r--r--openbsc/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/openbsc/Makefile.am b/openbsc/Makefile.am
new file mode 100644
index 000000000..4ce11cec5
--- /dev/null
+++ b/openbsc/Makefile.am
@@ -0,0 +1,13 @@
+AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+SUBDIRS = include src tests
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = openbsc.pc libsccp.pc
+
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version