aboutsummaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 5a231074c..cc2e277b5 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,3 +1,15 @@
SUBDIRS = \
examples \
$(NULL)
+
+msc: \
+ $(builddir)/handover.png \
+ $(builddir)/assignment.png \
+ $(NULL)
+
+$(builddir)/%.png: $(srcdir)/%.msc
+ mscgen -T png -o $@ $<
+
+.PHONY: poll
+poll:
+ while true; do $(MAKE) msc; sleep 1; done