aboutsummaryrefslogtreecommitdiffstats
path: root/tests/bsc-nat/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-07-19 16:48:42 +0200
committerNeels Hofmeyr <neels@hofmeyr.de>2017-08-30 14:09:31 +0200
commitbecfc4cb1ba9d759915a5b430aedc0d29c67858b (patch)
tree5dcf6925ed39c2433571f3718e8350e9e69b47f0 /tests/bsc-nat/Makefile.am
parentc4c794c6c735b63ba3b5021e016d4296ef601cca (diff)
move to osmo-mgw.git: osmo-bsc_mgcp and libmgcp as libosmo-legacy-mgcp
Rewire build and includes to libosmo-legacy-mgcp. Drop osmo-bsc_mgcp and related python tests, now found in osmo-mgw.git. libosmo-legacy-mgcp is installed from osmo-mgw, hence add the dependency to jenkins.sh (so far using the pre_release branch). Change-Id: Ic99d681759edce11564da62500c2aac5cf5fffe2
Diffstat (limited to 'tests/bsc-nat/Makefile.am')
-rw-r--r--tests/bsc-nat/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/bsc-nat/Makefile.am b/tests/bsc-nat/Makefile.am
index 40be3a32f..74838a984 100644
--- a/tests/bsc-nat/Makefile.am
+++ b/tests/bsc-nat/Makefile.am
@@ -12,6 +12,7 @@ AM_CFLAGS = \
$(LIBOSMOSCCP_CFLAGS) \
$(LIBOSMOABIS_CFLAGS) \
$(LIBOSMONETIF_CFLAGS) \
+ $(LIBOSMOLEGACYMGCP_CFLAGS) \
$(COVERAGE_CFLAGS) \
$(NULL)
@@ -45,7 +46,6 @@ bsc_nat_test_LDADD = \
$(top_builddir)/src/libfilter/libfilter.a \
$(top_builddir)/src/libbsc/libbsc.a \
$(top_builddir)/src/libcommon-cs/libcommon-cs.a \
- $(top_builddir)/src/libmgcp/libmgcp.a \
$(top_builddir)/src/libtrau/libtrau.a \
$(top_builddir)/src/libcommon/libcommon.a \
$(LIBOSMOCORE_LIBS) \
@@ -55,5 +55,7 @@ bsc_nat_test_LDADD = \
$(LIBOSMOABIS_LIBS) \
$(LIBOSMONETIF_LIBS) \
$(LIBOSMOCTRL_LIBS) \
+ $(LIBOSMOLEGACYMGCP_LIBS) \
+ $(LIBRARY_GSM) \
-lrt \
$(NULL)