aboutsummaryrefslogtreecommitdiffstats
path: root/tests/acc/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2020-07-16 20:53:21 +0200
committerlaforge <laforge@osmocom.org>2020-07-29 20:09:47 +0000
commitdeaa6fd624903c60a6d83bd02b430376203dcee8 (patch)
treeb278930231d4241541d571724e4d971b06e8ce92 /tests/acc/Makefile.am
parent3e2e820d52ad0c60f8eba226750b0355e6538664 (diff)
Introduce support for ACC subset rotation
See updated documentation section in manuals/chapters/bts.adoc regarding an explanation on how the system works. Related: SYS#4911 Change-Id: I952c9eeae02809c7184078c655574ec817902e06
Diffstat (limited to 'tests/acc/Makefile.am')
-rw-r--r--tests/acc/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/acc/Makefile.am b/tests/acc/Makefile.am
new file mode 100644
index 000000000..4726ddc72
--- /dev/null
+++ b/tests/acc/Makefile.am
@@ -0,0 +1,37 @@
+AM_CPPFLAGS = \
+ $(all_includes) \
+ -I$(top_srcdir)/include \
+ $(NULL)
+
+AM_CFLAGS = \
+ -Wall \
+ -ggdb3 \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOABIS_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
+ $(NULL)
+
+EXTRA_DIST = \
+ acc_test.ok \
+ $(NULL)
+
+noinst_PROGRAMS = \
+ acc_test \
+ $(NULL)
+
+acc_test_SOURCES = \
+ acc_test.c \
+ $(NULL)
+
+acc_test_LDADD = \
+ $(top_builddir)/src/osmo-bsc/abis_nm.o \
+ $(top_builddir)/src/osmo-bsc/acc.o \
+ $(top_builddir)/src/osmo-bsc/bts.o \
+ $(top_builddir)/src/osmo-bsc/bts_trx.o \
+ $(top_builddir)/src/osmo-bsc/gsm_data.o \
+ $(top_builddir)/src/osmo-bsc/net_init.o \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOABIS_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(NULL)