aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2021-09-14 11:05:28 +0200
committerneels <nhofmeyr@sysmocom.de>2021-11-10 13:27:43 +0000
commite0458c2e005de048ac2940875ee2e20ad497c891 (patch)
tree3901fb8691842f85db068fe01b85b024fbe1e7cb /tests/Makefile.am
parente455f0ab02a130795e4d2869355624d88064b6d9 (diff)
add time_cc API: cumlative counter for time, reported as rate_ctr
This is a candidate for adding to libosmocore (as osmo_time_cc), but let's first use this in osmo-bsc to make sure that it works as intended. I started out expecting to be done with this in half an hour, but I found out that accumulating elapsed time to an integer counter has a staggering amount of complexity to it, and a million pitfalls. The intended use is to report allAvailableSDCCHAllocated and allAvailableTCHAllocated performance indicators in OsmoBSC. Hopefully this will also be generally useful elsewhere, to be worth the effort. Related: SYS#4878 Change-Id: Icdd36f27cb54b2e1b940c9e6404ba9dd3692a310
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 762561e90..aefaae857 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -7,6 +7,7 @@ SUBDIRS = \
subscr \
nanobts_omlattr \
handover \
+ time_cc \
$(NULL)
# The `:;' works around a Bash 3.2 bug when the output is not writeable.