aboutsummaryrefslogtreecommitdiffstats
path: root/src/libbsc/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-05-30 01:39:43 +0200
committerHarald Welte <laforge@gnumonks.org>2018-06-02 20:56:17 +0200
commitc997ceb750a67baef1a05590febe1c678b287d8f (patch)
treee50b2bf3fe565546316577aa18096bffb9bb3497 /src/libbsc/Makefile.am
parent00965dca2bd78cc57ddb3989b365226908ff1c31 (diff)
Add initial 3GPP LCLS support to OsmoBSC
This code contains the following code: * receive/parse/interpret LCLS specific BSSMAP IEs and PDUs * osmo_fsm handling the various states and their transitions * call leg correlation (finding the other subscr_conn with same GCR) * communication between the two call-leg LCLS FSMs * detection of supported / unsupported LCLS configurations * display of GCR / LCLS information in "show conns" * switch the media streams locally using MDCX to the MGW Closes: OS#1602 Change-Id: I614fade62834def5cafc94c4d2578cd747a3f9f7
Diffstat (limited to 'src/libbsc/Makefile.am')
-rw-r--r--src/libbsc/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libbsc/Makefile.am b/src/libbsc/Makefile.am
index d215e14f9..2e447292f 100644
--- a/src/libbsc/Makefile.am
+++ b/src/libbsc/Makefile.am
@@ -65,5 +65,6 @@ libbsc_a_SOURCES = \
handover_decision_2.c \
bsc_subscr_conn_fsm.c \
meas_feed.c \
+ osmo_bsc_lcls.c \
$(NULL)