aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2009-02-20 18:33:00 +0000
committerHolger Freyther <zecke@selfish.org>2009-02-20 18:33:00 +0000
commit3281f6e2338de0aea5a164e366483f1bf5573976 (patch)
tree05d070edeb726d8e61fbb6873cadb108bfd1fa01 /src/Makefile.am
parent11fa29c169b9d0b02c1cd32e5683e038e7f494b5 (diff)
[build] Create a libbsc.a as noinst_LIBRARY, link bsc_hack and tests against it
Link the tests against the libbsc.a to avoid most of the breakage when creating new symbols.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f89836c89..412e1e30e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,13 +2,16 @@ INCLUDES = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS=-Wall
sbin_PROGRAMS = bsc_hack bs11_config ipaccess-find
+noinst_LIBRARIES = libbsc.a
-bsc_hack_SOURCES = bsc_hack.c abis_rsl.c abis_nm.c gsm_04_08.c gsm_data.c \
+libbsc_a_SOURCES = abis_rsl.c abis_nm.c gsm_04_08.c gsm_data.c \
gsm_subscriber.c msgb.c select.c chan_alloc.c timer.c debug.c db.c \
gsm_04_11.c telnet_interface.c telnet_parser.l subchan_demux.c \
trau_frame.c trau_mux.c paging.c e1_config.c e1_input.c tlv_parser.c \
input/misdn.c input/ipaccess.c signal.c gsm_utils.c
-bsc_hack_LDADD = -ldl -ldbi
+
+bsc_hack_SOURCES = bsc_hack.c
+bsc_hack_LDADD = libbsc.a -ldl -ldbi
bs11_config_SOURCES = bs11_config.c abis_nm.c gsm_data.c msgb.c debug.c select.c timer.c rs232.c tlv_parser.c