aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/sgsn/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2014-12-12 15:01:37 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-01-10 21:26:18 +0100
commita6ddc2d99f8463edb0b5eacf080db0b5ca571efc (patch)
tree0de9ea5d89c2e0a36cb4acbecdca73f24649159c /openbsc/tests/sgsn/Makefile.am
parentf3a271fa73ea58a628a51aa310e1da20a5526f31 (diff)
gprs: Add subscriber functions to create/handle GSUP messages
This patch extends gprs_subscr_query_auth_info and gprs_subscr_location_update to create GSUP messages with the help of a static gprs_subscr_tx_gsup_message function. A corresponding gprs_subscr_rx_gsup_message is added which takes a messages, gets the subscr, and updates it accordingly. Sponsored-by: On-Waves ehf [hfreyther: Added a msgb_free gprs_subscr_tx_gsup_message]
Diffstat (limited to 'openbsc/tests/sgsn/Makefile.am')
-rw-r--r--openbsc/tests/sgsn/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/openbsc/tests/sgsn/Makefile.am b/openbsc/tests/sgsn/Makefile.am
index 50c37d627..c8dccfe07 100644
--- a/openbsc/tests/sgsn/Makefile.am
+++ b/openbsc/tests/sgsn/Makefile.am
@@ -21,6 +21,8 @@ sgsn_test_LDADD = \
$(top_builddir)/src/gprs/sgsn_vty.o \
$(top_builddir)/src/gprs/sgsn_libgtp.o \
$(top_builddir)/src/gprs/sgsn_auth.o \
+ $(top_builddir)/src/gprs/gprs_gsup_messages.o \
+ $(top_builddir)/src/gprs/gprs_utils.o \
$(top_builddir)/src/gprs/gprs_subscriber.o \
$(top_builddir)/src/libcommon/libcommon.a \
$(LIBOSMOCORE_LIBS) \