aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/osmo-cscn/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-03-21 22:27:15 +0100
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-03-22 19:54:09 +0100
commitdebb0e386871e64a769d7414b71bedec09d7e76a (patch)
tree4c2dcaec7f22257e2d650ceacc5759805f5853f7 /openbsc/src/osmo-cscn/Makefile.am
parentd025a3cfbb53f690a4ebbd628cafda81c1b34bc7 (diff)
cscn: implement integrity protection
Upon authentication response, initiate integrity protection for Iu by sending a Security Mode Command (IK), with hardcoded auth tuple so far. Implement RANAP event handling to receive Security Mode Complete message, adding stubs for the other events; in new files osmo-cscn/iucs_ranap.[hc] to keep RANAP dependencies separate, and particularly out of libmsc. Upon receiving Security Mode Complete, call the security operation callback (conn->sec_operation->cb) to complete the Location Update. Introduce enum integrity_protection_state constants to indicate integrity protection, record in gsm_subscriber_conn.iu.integrity_protection. Make subscr_conn_lookup_iu() non-static and declare in iu_cs.h to be able to call from iucs_ranap.c's Security Mode Complete event. Implement dummy iu_tx_sec_mode_cmd() to allow tests to build without RANAP dependencies. In cscn_main.c, call iucs_rx_ranap_event(), to populate the struct gsm_network struct with cscn_network explicitly (don't share cscn_network across compilation scopes because it's ugly).
Diffstat (limited to 'openbsc/src/osmo-cscn/Makefile.am')
-rw-r--r--openbsc/src/osmo-cscn/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/openbsc/src/osmo-cscn/Makefile.am b/openbsc/src/osmo-cscn/Makefile.am
index 66109ff38..545decb47 100644
--- a/openbsc/src/osmo-cscn/Makefile.am
+++ b/openbsc/src/osmo-cscn/Makefile.am
@@ -1,4 +1,5 @@
-AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir) \
+ -DCOMPILING_LIBMSC=1
AM_CFLAGS=-Wall $(COVERAGE_CFLAGS) \
$(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOVTY_CFLAGS) \
$(LIBOSMOCTRL_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(LIBSMPP34_CFLAGS) \
@@ -8,7 +9,9 @@ AM_LDFLAGS = $(COVERAGE_LDFLAGS)
bin_PROGRAMS = osmo-cscn
-osmo_cscn_SOURCES = cscn_main.c
+noinst_HEADERS = iucs_ranap.h
+
+osmo_cscn_SOURCES = cscn_main.c iucs_ranap.c
osmo_cscn_LDADD = \
$(top_builddir)/src/libiu/libiu.a \