aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/osmo-bsc_nat/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-03-03 23:36:48 +0100
committerHarald Welte <laforge@gnumonks.org>2011-03-03 23:36:48 +0100
commita17faf8512992a53a14e8b615f5369be05c5f0cc (patch)
tree044ab53a68634ddcf12130bbc1275e86423e449f /openbsc/src/osmo-bsc_nat/Makefile.am
parent31c00f7d6fa63937f2c973157d196a427f6eef95 (diff)
Rename bsc_nat -> osmo-bsc_nat and bsc_mgcp -> osmo-bsc_mgcp
This now enforces a unique structure: All of our main daemon programs start with an "osmo-" prefix.
Diffstat (limited to 'openbsc/src/osmo-bsc_nat/Makefile.am')
-rw-r--r--openbsc/src/osmo-bsc_nat/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/openbsc/src/osmo-bsc_nat/Makefile.am b/openbsc/src/osmo-bsc_nat/Makefile.am
new file mode 100644
index 000000000..c7905ce3a
--- /dev/null
+++ b/openbsc/src/osmo-bsc_nat/Makefile.am
@@ -0,0 +1,13 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(LIBOSMOSCCP_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(LIBOSMOVTY_LIBS) $(COVERAGE_LDFLAGS)
+
+bin_PROGRAMS = osmo-bsc_nat
+
+
+osmo_bsc_nat_SOURCES = bsc_filter.c bsc_mgcp_utils.c bsc_nat.c bsc_nat_utils.c \
+ bsc_nat_vty.c bsc_sccp.c bsc_ussd.c
+osmo_bsc_nat_LDADD = $(top_builddir)/src/common/libcommon.a \
+ $(top_builddir)/src/mgcp/libmgcp.a $(top_builddir)/src/bsc/libbsc.a \
+ $(top_builddir)/src/abis/libabis.a $(top_builddir)/src/trau/libtrau.a \
+ -lrt $(LIBOSMOSCCP_LIBS)