aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libbsc/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-05-10 12:50:31 +0200
committerHarald Welte <laforge@gnumonks.org>2016-12-02 12:09:15 +0000
commit43273c63de6f457c47105e1432ea28ebf914d135 (patch)
treee5afbf410bb6358986f5ed3fdc40be4873a90497 /openbsc/src/libbsc/Makefile.am
parenteb52aad198323fd86fbffc3bab3be4e5d394b205 (diff)
factor out gen of USSD notify and release complete to libosmocore
Both libmsc and libbsc will need distinct gsm0480_send_ussdNotify() and gsm0480_send_releaseComplete() functions, since there will be distinct subscriber connection structs. Rename to msc_send_ussd_notify() and msc_send_ussd_release_complete(), and add the same in libbsc with bsc_ prefix in new file gsm_04_80_utils.c. In preparation of this patch, the message generation part of these functions has been added to libosmocore as gsm0480_create_ussd_notify() and gsm0480_create_ussd_release_complete(). Use these. Adjust all libmsc and libbsc callers according to use the msc_* or bsc_* implementation, respectively. Change-Id: I33a84e3c28576ced91d2ea24103123431f551173
Diffstat (limited to 'openbsc/src/libbsc/Makefile.am')
-rw-r--r--openbsc/src/libbsc/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/openbsc/src/libbsc/Makefile.am b/openbsc/src/libbsc/Makefile.am
index 8c5381777..b8e77e69a 100644
--- a/openbsc/src/libbsc/Makefile.am
+++ b/openbsc/src/libbsc/Makefile.am
@@ -41,6 +41,7 @@ libbsc_a_SOURCES = \
bsc_api.c \
bsc_msc.c bsc_vty.c \
gsm_04_08_utils.c \
+ gsm_04_80_utils.c \
bsc_init.c \
bts_init.c \
bsc_rf_ctrl.c \