aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/include/openbsc/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2009-08-09 13:47:35 +0200
committerHarald Welte <laforge@gnumonks.org>2009-08-09 13:47:35 +0200
commitedcc5273713b92b37b02ae95e5ff70d44af63e76 (patch)
tree3b069a4e39fcd53f815e8c57394b075de20a5b57 /openbsc/include/openbsc/Makefile.am
parent42b4557fca47c07ea68cbfd691589c2346ec52bb (diff)
Add new BSC RLL layer of code
A caller can call rll_establish(lchan, link_id) and a callback to the GSM RLL code. He will get called back if the RLL link is established or receives some error message, or the establishment times out. We need this for proper SMS implementation, where we need to restablish a SAPI3 RLL link before transmitting the actual CP-DATA messages.
Diffstat (limited to 'openbsc/include/openbsc/Makefile.am')
-rw-r--r--openbsc/include/openbsc/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/openbsc/include/openbsc/Makefile.am b/openbsc/include/openbsc/Makefile.am
index adef573e5..c1f3f139d 100644
--- a/openbsc/include/openbsc/Makefile.am
+++ b/openbsc/include/openbsc/Makefile.am
@@ -2,4 +2,5 @@ noinst_HEADERS = abis_nm.h abis_rsl.h debug.h db.h gsm_04_08.h gsm_data.h \
gsm_subscriber.h linuxlist.h msgb.h select.h tlv.h gsm_04_11.h \
timer.h misdn.h chan_alloc.h telnet_interface.h paging.h \
subchan_demux.h trau_frame.h e1_input.h trau_mux.h signal.h \
- gsm_utils.h ipaccess.h rs232.h openbscdefines.h rtp_proxy.h
+ gsm_utils.h ipaccess.h rs232.h openbscdefines.h rtp_proxy.h \
+ bsc_rll.h