aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Willmann <dwillmann@sysmocom.de>2020-11-06 15:23:52 +0100
committerlaforge <laforge@osmocom.org>2020-11-09 10:58:21 +0000
commit47899f1695b59a8d81162a513ff649a834b1fd0b (patch)
tree1f81d7efd229d3214d94d407d4fa534dd168032c /configure.ac
parent39b92ff33a65b0c067b033f5e36cec20325e3f97 (diff)
configure.ac: Require python3 for ext_tests
The python scripts already use #!/usr/bin/env python3 so it was pure coincidence that the tests are working. Change-Id: Id5745d5ff5ff1072ccfbf9ad50b2d67f3ea95583
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ed9b2cb3f..f1f17b8b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,9 +154,9 @@ AC_ARG_ENABLE([external_tests],
[Include the VTY/CTRL tests in make check [default=no]]),
[enable_ext_tests="$enableval"],[enable_ext_tests="no"])
if test "x$enable_ext_tests" = "xyes" ; then
- AC_CHECK_PROG(PYTHON2_AVAIL,python2,yes)
- if test "x$PYTHON2_AVAIL" != "xyes" ; then
- AC_MSG_ERROR([Please install python2 to run the VTY/CTRL tests.])
+ AC_CHECK_PROG(PYTHON3_AVAIL,python3,yes)
+ if test "x$PYTHON3_AVAIL" != "xyes" ; then
+ AC_MSG_ERROR([Please install python3 to run the VTY/CTRL tests.])
fi
AC_CHECK_PROG(OSMOTESTEXT_CHECK,osmotestvty.py,yes)
if test "x$OSMOTESTEXT_CHECK" != "xyes" ; then