aboutsummaryrefslogtreecommitdiffstats
path: root/tests/channel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/channel/Makefile.am')
-rw-r--r--tests/channel/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/channel/Makefile.am b/tests/channel/Makefile.am
new file mode 100644
index 000000000..bf709ff28
--- /dev/null
+++ b/tests/channel/Makefile.am
@@ -0,0 +1,10 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS=-Wall -ggdb3 $(LIBOSMOCORE_CFLAGS)
+
+noinst_PROGRAMS = channel_test
+
+channel_test_SOURCES = channel_test.c
+channel_test_LDADD = -ldl -ldbi $(LIBOSMOCORE_LIBS) \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(top_builddir)/src/libbsc/libbsc.a \
+ $(top_builddir)/src/libmsc/libmsc.a