aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/subscr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/subscr/Makefile.am')
-rw-r--r--openbsc/tests/subscr/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/openbsc/tests/subscr/Makefile.am b/openbsc/tests/subscr/Makefile.am
index ad8b20c0c..6342444ff 100644
--- a/openbsc/tests/subscr/Makefile.am
+++ b/openbsc/tests/subscr/Makefile.am
@@ -19,10 +19,13 @@ AM_LDFLAGS = \
EXTRA_DIST = \
subscr_test.ok \
+ bsc_subscr_test.ok \
+ bsc_subscr_test.err \
$(NULL)
noinst_PROGRAMS = \
subscr_test \
+ bsc_subscr_test \
$(NULL)
subscr_test_SOURCES = \
@@ -40,3 +43,19 @@ subscr_test_LDADD = \
$(LIBSMPP34_LIBS) \
$(LIBOSMOVTY_LIBS) \
$(NULL)
+
+bsc_subscr_test_SOURCES = \
+ bsc_subscr_test.c \
+ $(NULL)
+
+bsc_subscr_test_LDADD = \
+ $(top_builddir)/src/libbsc/libbsc.a \
+ $(top_builddir)/src/libcommon-cs/libcommon-cs.a \
+ $(top_builddir)/src/libtrau/libtrau.a \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOABIS_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(LIBSMPP34_LIBS) \
+ $(LIBOSMOVTY_LIBS) \
+ $(NULL)