aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/sgsn/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/sgsn/Makefile.am')
-rw-r--r--openbsc/tests/sgsn/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/openbsc/tests/sgsn/Makefile.am b/openbsc/tests/sgsn/Makefile.am
index d148c4879..cf8810160 100644
--- a/openbsc/tests/sgsn/Makefile.am
+++ b/openbsc/tests/sgsn/Makefile.am
@@ -56,7 +56,8 @@ sgsn_test_LDADD = \
$(top_builddir)/src/gprs/gprs_gb_parse.o \
$(top_builddir)/src/gprs/oap.o \
$(top_builddir)/src/gprs/oap_messages.o \
- $(top_builddir)/src/gprs/gprs_llc_xid.o \
+ $(top_builddir)/src/gprs/gprs_llc_xid.o \
+ $(top_builddir)/src/gprs/gprs_sndcp_xid.o \
$(top_builddir)/src/libcommon/libcommon.a \
$(LIBOSMOABIS_LIBS) \
$(LIBOSMOCORE_LIBS) \
@@ -66,7 +67,9 @@ sgsn_test_LDADD = \
$(LIBCRYPTO_LIBS) \
$(LIBGTP_LIBS) \
-lrt \
+ -lm \
$(NULL)
+
if BUILD_IU
sgsn_test_LDADD += \
$(top_builddir)/src/libiu/libiu.a \