aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/channel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/channel/Makefile.am')
-rw-r--r--openbsc/tests/channel/Makefile.am16
1 files changed, 5 insertions, 11 deletions
diff --git a/openbsc/tests/channel/Makefile.am b/openbsc/tests/channel/Makefile.am
index 8593b5a13..bf709ff28 100644
--- a/openbsc/tests/channel/Makefile.am
+++ b/openbsc/tests/channel/Makefile.am
@@ -3,14 +3,8 @@ AM_CFLAGS=-Wall -ggdb3 $(LIBOSMOCORE_CFLAGS)
noinst_PROGRAMS = channel_test
-channel_test_SOURCES = channel_test.c \
- $(top_srcdir)/src/db.c \
- $(top_srcdir)/src/gsm_subscriber_base.c \
- $(top_srcdir)/src/gsm_subscriber.c \
- $(top_srcdir)/src/debug.c \
- $(top_srcdir)/src/gsm_data.c \
- $(top_srcdir)/src/abis_nm.c \
- $(top_srcdir)/src/bts_ipaccess_nanobts.c \
- $(top_srcdir)/src/bts_siemens_bs11.c
-channel_test_LDADD = -ldl -ldbi $(LIBOSMOCORE_LIBS)
-
+channel_test_SOURCES = channel_test.c
+channel_test_LDADD = -ldl -ldbi $(LIBOSMOCORE_LIBS) \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(top_builddir)/src/libbsc/libbsc.a \
+ $(top_builddir)/src/libmsc/libmsc.a