aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libabis/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/src/libabis/Makefile.am')
-rw-r--r--openbsc/src/libabis/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/openbsc/src/libabis/Makefile.am b/openbsc/src/libabis/Makefile.am
new file mode 100644
index 000000000..7f5ac47cc
--- /dev/null
+++ b/openbsc/src/libabis/Makefile.am
@@ -0,0 +1,13 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(COVERAGE_LDFLAGS)
+
+noinst_LIBRARIES = libabis.a
+
+libabis_a_SOURCES = e1_input.c e1_input_vty.c \
+ input/misdn.c \
+ input/ipaccess.c \
+ input/dahdi.c \
+ input/lapd.c
+
+EXTRA_DIST = input/lapd.h