aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/contrib/systemd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/contrib/systemd/Makefile.am')
-rw-r--r--openbsc/contrib/systemd/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/openbsc/contrib/systemd/Makefile.am b/openbsc/contrib/systemd/Makefile.am
new file mode 100644
index 000000000..69f973e5e
--- /dev/null
+++ b/openbsc/contrib/systemd/Makefile.am
@@ -0,0 +1,14 @@
+if HAVE_SYSTEMD
+SYSTEMD_SERVICES = osmo-nitb.service osmo-bsc-mgcp.service
+
+if BUILD_NAT
+SYSTEMD_SERVICES += osmo-bsc-nat.service
+endif
+
+if BUILD_BSC
+SYSTEMD_SERVICES += osmo-bsc-sccplite.service
+endif
+
+EXTRA_DIST = $(SYSTEMD_SERVICES)
+systemdsystemunit_DATA = $(SYSTEMD_SERVICES)
+endif # HAVE_SYSTEMD