aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/configure.in')
-rw-r--r--openbsc/configure.in48
1 files changed, 48 insertions, 0 deletions
diff --git a/openbsc/configure.in b/openbsc/configure.in
new file mode 100644
index 000000000..b886e7ac1
--- /dev/null
+++ b/openbsc/configure.in
@@ -0,0 +1,48 @@
+dnl Process this file with autoconf to produce a configure script
+AC_INIT
+
+AM_INIT_AUTOMAKE(openbsc, 0.0alpha1)
+
+dnl checks for programs
+AC_PROG_MAKE_SET
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+dnl checks for libraries
+AC_SEARCH_LIBS(crypt, crypt,
+ [LIBCRYPT="-lcrypt"; AC_DEFINE([VTY_CRYPT_PW], [], [Use crypt functionality of vty.])])
+
+dnl checks for header files
+AC_HEADER_STDC
+
+dnl Checks for typedefs, structures and compiler characteristics
+
+# The following test is taken from WebKit's webkit.m4
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -fvisibility=hidden "
+AC_MSG_CHECKING([if ${CC} supports -fvisibility=hidden])
+AC_COMPILE_IFELSE([char foo;],
+ [ AC_MSG_RESULT([yes])
+ SYMBOL_VISIBILITY="-fvisibility=hidden"],
+ AC_MSG_RESULT([no]))
+CFLAGS="$saved_CFLAGS"
+AC_SUBST(SYMBOL_VISIBILITY)
+
+
+dnl Generate the output
+AM_CONFIG_HEADER(bscconfig.h)
+
+AC_OUTPUT(
+ openbsc.pc
+ include/openbsc/Makefile
+ include/vty/Makefile
+ include/Makefile
+ src/Makefile
+ tests/Makefile
+ tests/debug/Makefile
+ tests/timer/Makefile
+ tests/sms/Makefile
+ tests/gsm0408/Makefile
+ tests/db/Makefile
+ Makefile)