aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/sndcp_xid/Makefile.am
diff options
context:
space:
mode:
authorPhilipp <pmaier@sysmocom.de>2016-08-10 12:08:03 +0200
committerHarald Welte <laforge@gnumonks.org>2016-09-24 03:17:58 +0000
commit22611be3d93b58ba96983247d71fa6be57fa0cb0 (patch)
treed3cf6edb86ad200de2689eabc45b6f70afa38264 /openbsc/tests/sndcp_xid/Makefile.am
parent308cb0719dca3ba8eed1eff2a2124d44f34d9a28 (diff)
SNDCP: add SNDCP-XID encoder/decoder and unit test
The SNDCP-XID (or layer-3 xid) is used to exchange layer-3 parameters such as compression. The encoder encodes a bytestream that is then sent as regular XID field from LLC. We will need the SNDCP-XID to negotiate the parameters for our upcomming GPRS data and header compression features Change-Id: If2d63fe2550864cafef3156b1dc0629037c49c1e
Diffstat (limited to 'openbsc/tests/sndcp_xid/Makefile.am')
-rw-r--r--openbsc/tests/sndcp_xid/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/openbsc/tests/sndcp_xid/Makefile.am b/openbsc/tests/sndcp_xid/Makefile.am
new file mode 100644
index 000000000..99b9d1a4f
--- /dev/null
+++ b/openbsc/tests/sndcp_xid/Makefile.am
@@ -0,0 +1,20 @@
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS=-Wall -ggdb3 $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBCARES_CFLAGS)
+
+EXTRA_DIST = sndcp_xid_test.ok
+
+noinst_PROGRAMS = sndcp_xid_test
+
+sndcp_xid_test_SOURCES = sndcp_xid_test.c
+
+sndcp_xid_test_LDADD = \
+ $(top_builddir)/src/gprs/gprs_sndcp_xid.o \
+ $(LIBOSMOABIS_LIBS) \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOGB_LIBS) \
+ $(LIBCARES_LIBS) \
+ $(LIBCRYPTO_LIBS) \
+ -lgtp -lrt -lm
+
+