aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/gsm0408/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2014-01-10 17:43:41 +0100
committerJacob Erlbeck <jerlbeck@sysmocom.de>2014-01-16 12:04:29 +0100
commit4b903b4afb5d593603b0d75a7d244f6c00e039ad (patch)
treec1ddab16d59f966c21f402d4d39c09c96ff67b19 /openbsc/tests/gsm0408/Makefile.am
parent65d114fe434ec4fff9b9abfedade05ce21da994e (diff)
si/test: Add tests for range encoding/decoding
This commit adds test range encoding tests. They check the property decoding(encoding(L)) = L and optionally dump the results and encoded sequences to stdout. There a 2 test modes: - A list of fixed tests - A random number based test loop per ARFCN list size (only dumps the first failing test) Sponsored-by: On-Waves ehf
Diffstat (limited to 'openbsc/tests/gsm0408/Makefile.am')
-rw-r--r--openbsc/tests/gsm0408/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/openbsc/tests/gsm0408/Makefile.am b/openbsc/tests/gsm0408/Makefile.am
index b000c0802..1c29ece12 100644
--- a/openbsc/tests/gsm0408/Makefile.am
+++ b/openbsc/tests/gsm0408/Makefile.am
@@ -8,4 +8,5 @@ gsm0408_test_SOURCES = gsm0408_test.c
gsm0408_test_LDADD = $(top_builddir)/src/libbsc/libbsc.a \
$(top_builddir)/src/libmsc/libmsc.a \
$(top_builddir)/src/libbsc/libbsc.a \
+ $(top_builddir)/src/libcommon/libcommon.a \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) -ldbi